Skip to main content
No exploitation reportedFix available

CVE-2016-5094

No exploitation reported by the sources we read.

  • Published2016-08-07
  • WeaknessCWE-190

Am I affected?

With a domain, we read the version its public headers and pages expose. A distribution build can carry the fix under an older number.

Description

Integer overflow in the php_html_entities function in ext/standard/html.c in PHP before 5.5.36 and 5.6.x before 5.6.22 allows remote attackers to cause a denial of service or possibly have unspecified other impact by triggering a large output string from the htmlspecialchars function.

Timeline

dates in UTC
  1. 2016-08-0710:59CVE publishedNVD

Observed activity

isMalicious corpus · updated 2026-11-04 09:37 UTC
Indicators tagged with this CVE, per day0 indicators over 7 days
Block these indicators
  • Firewall list (EDL, text): https://api.ismalicious.com/edl/cve/CVE-2016-5094?format=txt
  • CSV export: https://api.ismalicious.com/edl/cve/CVE-2016-5094?format=csv
  • TAXII collection of exploited CVEs
  • The EDL and CSV take an API key on the Pro plan.

Versions per branch

NVD
PHP
BranchAffectedFixed in
5.5≤ 5.5.36no fix published
5.6= 5.6.0no fix published
5.6= 5.6.1no fix published
5.6= 5.6.2no fix published
5.6= 5.6.3no fix published
5.6= 5.6.4no fix published
5.6= 5.6.5no fix published
5.6= 5.6.6no fix published
5.6= 5.6.7no fix published
5.6= 5.6.8no fix published
5.6= 5.6.9no fix published
5.6= 5.6.10no fix published

as publishedRanges as NVD and OSV publish them; a distribution’s build can be fixed under an older number.

Distribution builds and vendor advisories

Packages from OSV.dev and products from the vendors' CSAF advisories.

version not verifiedVersions not verified: read as OSV.dev and the vendors publish them, not checked against each vendor's release list.

Packages

  • imapSUSE:Linux Enterprise Workstation Extension 12 SP1all versions · fixed in 2007e_suse-19.1
  • imapSUSE:Linux Enterprise Workstation Extension 12all versions · fixed in 2007e_suse-19.1
  • imapSUSE:Linux Enterprise Software Development Kit 12 SP1all versions · fixed in 2007e_suse-19.1
  • imapSUSE:Linux Enterprise Software Development Kit 12all versions · fixed in 2007e_suse-19.1
  • imapSUSE:Linux Enterprise Module for Web and Scripting 12all versions · fixed in 2007e_suse-19.1
  • imapSUSE:Linux Enterprise Desktop 12 SP1all versions · fixed in 2007e_suse-19.1
  • imapSUSE:Linux Enterprise Desktop 12all versions · fixed in 2007e_suse-19.1
  • phpTuxCare:CentOS:6all versions · fixed in 5.3.3-51.el6.cloudlinuxand 26 other packages

23 more package ranges on OSV.dev

Vendor advisories

  • RHSA-2016:2750 Red Hat Product Security251 products fixed

    Red Hat Security Advisory: rh-php56 security, bug fix, and enhancement update

Full record on NVD

Fix

  1. Vendor fix Red Hat Product Security RHSA-2016:2750 · 251 productsFor details on how to apply this update, which includes the changes described in this advisory, refer to: https://access.redhat.com/articles/11258 After installing the updated packages, the httpd daemon must be restarted for the update to take effect.

Advisories and patches

Detection

Nuclei template
none so far
ProjectDiscovery
Exploit-DB
no entry
Exploit-DB
Proof-of-concept repositories
none listed
PoC-in-GitHub
Metasploit modules
none listed
Metasploit Framework

Sources

  • NVDCVSS 3.08.6read 2026-10-23
  • NVDCVSS 2.07.5read 2026-10-23
  • NVDweakness (CWE)CWE-190read 2026-10-23
  • FIRST EPSSEPSS score4.5 %2026-11-03
  • OSVaffected packages—

Identifiers

Technical details

CVSS v3 Vector
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:H
Published
2016-08-07
Last Modified
2026-06-17
NVD status
Modified

Frequently asked questions

What is CVE-2016-5094?

Integer overflow in the php_html_entities function in ext/standard/html.c in PHP before 5.5.36 and 5.6.x before 5.6.22 allows remote attackers to cause a denial of service or possibly have unspecified other impact by triggering a large output string from the htmlspecialchars function.

Is CVE-2016-5094 actively exploited?

Active exploitation of CVE-2016-5094 has not been confirmed. Its EPSS score was 4.5% on 2026-11-03, the estimated probability of exploitation in the next 30 days.

What is the CVSS score for CVE-2016-5094?

CVE-2016-5094 has a CVSS v3 base score of 8.6 (HIGH severity), with vector string CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:H.

Running rh-php56 security, bug fix,? Hear about its next vulnerability

Surveillance reads the versions in your stack — a domain, a lockfile or a list — checks each CVE against the ranges its sources publish, and alerts you when one you run is exploited or enters CISA KEV. A version it cannot read stays « version not verified ».

No credit card required · No monthly cap on website lookups · 250 API requests/month

Sources for this record