CVE-2016-10542
A public proof of concept exists; no exploitation attested.
- Published2018-05-31
- Fixed in1.1.1
- WeaknessCWE-20 · CWE-400
Am I affected?
Debian, Ubuntu or Red Hat sometimes backport a fix without changing the upstream version number: such a version reads « to verify », never « affected ».With a domain, we read the version its public headers and pages expose. A distribution build can carry the fix under an older number.
Description
ws is a "simple to use, blazing fast and thoroughly tested websocket client, server and console for node.js, up-to-date against RFC-6455". By sending an overly long websocket payload to a `ws` server, it is possible to crash the node process. This affects ws 1.1.0 and earlier.
Timeline
dates in UTC- 2018-05-3120:29CVE publishedNVD
Observed activity
isMalicious corpus · updated 2026-11-03 21:37 UTCBlock these indicators
- Firewall list (EDL, text): https://api.ismalicious.com/edl/cve/CVE-2016-10542?format=txt
- CSV export: https://api.ismalicious.com/edl/cve/CVE-2016-10542?format=csv
- TAXII collection of exploited CVEs
- The EDL and CSV take an API key on the Pro plan.
Versions per branch
OSV · NVD| Branch | Affected | Fixed in | Source |
|---|---|---|---|
| 1.1 | < 1.1.1 | 1.1.1 | OSV |
| Branch | Affected | Fixed in | Source |
|---|---|---|---|
| 1.1 | ≤ 1.1.0 | no fix published | NVD |
as publishedRanges as NVD and OSV publish them; a distribution’s build can be fixed under an older number.
Distribution builds and vendor advisories
Packages from OSV.dev and products from the vendors' CSAF advisories.
version not verifiedVersions not verified: read as OSV.dev and the vendors publish them, not checked against each vendor's release list.
Packages
- cube-1.4MinimOSall versions · no fixed version listedand 1 other package
- node-wsUbuntu:18.04:LTSall versions · no fixed version listed
- node-wsUbuntu:16.04:LTSall versions · no fixed version listed
- node-wsDebian:14all versions · fixed in 1.1.0+ds1.e6ddaae4-5
- node-wsDebian:13all versions · fixed in 1.1.0+ds1.e6ddaae4-5
- node-wsDebian:12all versions · fixed in 1.1.0+ds1.e6ddaae4-5
- wsTuxCare:npmfrom 0.8.1-tuxcare.0 · fixed in 0.8.1-tuxcare.2
Fix
- Update ws to 1.1.1
Detection
- Nuclei template
- none so far ProjectDiscovery
- Exploit-DB
- no entry Exploit-DB
- Proof-of-concept repositories
- none listed PoC-in-GitHub
- Metasploit modules
- 1 moduleauxiliary/dos/http/ws_dosrank: normalModule metadata: Metasploit Framework, © Rapid7, Inc., BSD-3-Clause. Metasploit Framework
Sources
- NVDCVSS 3.07.5read 2026-10-23
- NVDCVSS 2.05read 2026-10-23
- CNAweakness (CWE)CWE-400known since 2026-10-23
- NVDweakness (CWE)CWE-20read 2026-10-23
- FIRST EPSSEPSS score7.4 %2026-11-03
- Metasploit FrameworkMetasploit modules1known since 2026-11-01
- OSVaffected packages—
- GitHub AdvisoriesadvisoryHIGH2020-06-16
Identifiers
- EUVD-2019-0237same flawENISA EUVD · LicenseRef-ENISA-legal-notice
- GHSA-6663-c963-2gqgsame flawGitHub Advisory Database · CC-BY-4.0
- MINI-2chg-g267-phx8same flawMinimOS · LicenseRef-unstated
- MINI-9wj4-66hj-xhx9same flawMinimOS · LicenseRef-unstated
- auxiliary/dos/http/ws_dosexploit moduleMetasploit Framework © Rapid7 · BSD-3-Clause
Technical details
- CVSS v3 Vector
- CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- Published
- 2018-05-31
- Last Modified
- 2026-06-17
- NVD status
- Modified
- GitHub Advisory
- GHSA-6663-c963-2gqg
Frequently asked questions
What is CVE-2016-10542?
Is CVE-2016-10542 actively exploited?
What is the CVSS score for CVE-2016-10542?
Running ws? Hear about its next vulnerability
Surveillance reads the versions in your stack — a domain, a lockfile or a list — checks each CVE against the ranges its sources publish, and alerts you when one you run is exploited or enters CISA KEV. A version it cannot read stays « version not verified ».
No credit card required · No monthly cap on website lookups · 250 API requests/month
Go further
- Following what attackers exploit right now? The CISA KEV additions of the month, with their patch deadlines.
- Running this software? Vulnerability monitoring alerts you to new vulnerabilities in your products.
Related vulnerabilities
Same product first, then the same vendor advisory and the same publication week.
- CVE-2026-44492same product
- CVE-2026-44496same product
- CVE-2019-10744same product
- CVE-2025-64756same product
- CVE-2021-32640same product
- CVE-2026-4800same product
- CVE-2026-25639same productAxios affected by Denial of Service via __proto__ Key in mergeConfig
- CVE-2025-48924same productApache Commons Lang, Apache Commons Lang: ClassUtils.getClass(...) can throw a StackOverflowError on very long inputs
Sources for this record
- CVE Program · CVE Program Terms of Use
- ENISA EU Vulnerability Database · ENISA legal notice §1.2 (reproduction authorised, provided the source is acknowledged)
- FIRST EPSS · EPSS terms of use (free use, attribution requested)
- GitHub Advisory Database · CC-BY-4.0 · GHSA-6663-c963-2gqg
- Metasploit Framework · BSD-3-Clause
- NVD · Public domain (17 U.S.C. § 105) for NVD-authored data; third-party content under its own terms
- OSV.dev · Per record, as its publisher states it: each row carries the label in sourceLicense when one is served