Skip to main content
Public proof of conceptFix available

CVE-2016-1000027

A public proof of concept exists; no exploitation attested.

  • Published2020-01-02
  • Fixed in6.0.0
  • WeaknessCWE-502

Am I affected?

With a domain, we read the version its public headers and pages expose. A distribution build can carry the fix under an older number.

Description

Pivotal Spring Framework through 5.3.16 suffers from a potential remote code execution (RCE) issue if used for Java deserialization of untrusted data. Depending on how the library is implemented within a product, this issue may or not occur, and authentication may be required. NOTE: the vendor's position is that untrusted data is not an intended use case. The product's behavior will not be changed because some users rely on deserialization of trusted data.

Timeline

dates in UTC
  1. 2020-01-0223:15CVE publishedNVD

Observed activity

isMalicious corpus · updated 2026-11-04 09:37 UTC
Indicators tagged with this CVE, per day0 indicators over 7 days
Block these indicators
  • Firewall list (EDL, text): https://api.ismalicious.com/edl/cve/CVE-2016-1000027?format=txt
  • CSV export: https://api.ismalicious.com/edl/cve/CVE-2016-1000027?format=csv
  • TAXII collection of exploited CVEs
  • The EDL and CSV take an API key on the Pro plan.

Versions per branch

NVD · OSV
Spring Framework
BranchAffectedFixed in
6.0< 6.0.06.0.0

as publishedRanges as NVD and OSV publish them; a distribution’s build can be fixed under an older number.

Distribution builds and vendor advisories

Packages from OSV.dev and products from the vendors' CSAF advisories.

version not verifiedVersions not verified: read as OSV.dev and the vendors publish them, not checked against each vendor's release list.

Packages

  • activemqCleanStartall versions · fixed in 5.19.8-r3
  • apache-activemq-5.19MinimOSall versions · no fixed version listedand 2 other packages
  • apache-nifiWolfiall versions · fixed in 0and 2 other packages
  • apache-nifiChainguardall versions · fixed in 0and 7 other packages
  • geoserver-2.28Chainguardall versions · fixed in 2.28.3-r0
  • io.root.org.springframework:spring-webRoot:Mavenall versions · fixed in 5.3.27-root.io.2
  • io.root.org.springframework:spring-webRoot:Mavenall versions · fixed in 4.0.3.RELEASE-root.io.3
  • io.root.org.springframework:spring-webRoot:Mavenall versions · fixed in 4.0.3.RELEASE-root.io.4

31 more package ranges on OSV.dev

Vendor advisories

  • CVE-2016-1000027 Red Hat Product Security

    spring: HttpInvokerServiceExporter readRemoteInvocation method untrusted java deserialization

Full record on NVD

Fix

  1. Update Spring Framework to 6.0.0

Advisories and patches

Detection

read 2026-11-03 22:42 UTC
Nuclei template
none so far
ProjectDiscovery
Exploit-DB
no entry
Exploit-DB
Metasploit modules
none listed
Metasploit Framework

Sources

Identifiers

Technical details

CVSS v3 Vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Published
2020-01-02
Last Modified
2026-10-07
NVD status
Modified
GitHub Advisory
GHSA-4wrc-f8pq-fpqp

Frequently asked questions

What is CVE-2016-1000027?

Pivotal Spring Framework through 5.3.16 suffers from a potential remote code execution (RCE) issue if used for Java deserialization of untrusted data. Depending on how the library is implemented within a product, this issue may or not occur, and authentication may be required. NOTE: the vendor's position is that untrusted data is not an intended use case. The product's behavior will not be changed because some users rely on deserialization of trusted data.

Is CVE-2016-1000027 actively exploited?

Active exploitation of CVE-2016-1000027 has not been confirmed. Its EPSS score was 33.2% on 2026-11-03, the estimated probability of exploitation in the next 30 days.

What is the CVSS score for CVE-2016-1000027?

CVE-2016-1000027 has a CVSS v3 base score of 9.8 (CRITICAL severity), with vector string CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H.

Running Spring Framework? Hear about its next vulnerability

Surveillance reads the versions in your stack — a domain, a lockfile or a list — checks each CVE against the ranges its sources publish, and alerts you when one you run is exploited or enters CISA KEV. A version it cannot read stays « version not verified ».

No credit card required · No monthly cap on website lookups · 250 API requests/month

Sources for this record