CVE-2015-7560
No exploitation reported by the sources we read.
- Published2016-03-13
- Fixed in4.3.6 · 4.2.9 · 4.1.23
- WeaknessCWE-284
Am I affected?
Debian, Ubuntu or Red Hat sometimes backport a fix without changing the upstream version number: such a version reads « to verify », never « affected ».With a domain, we read the version its public headers and pages expose. A distribution build can carry the fix under an older number.
Description
The SMB1 implementation in smbd in Samba 3.x and 4.x before 4.1.23, 4.2.x before 4.2.9, 4.3.x before 4.3.6, and 4.4.x before 4.4.0rc4 allows remote authenticated users to modify arbitrary ACLs by using a UNIX SMB1 call to create a symlink, and then using a non-UNIX SMB1 call to write to the ACL content.
Timeline
dates in UTC- 2016-03-1322:59CVE publishedNVD
- 2026-10-2319:23EPSS crossed 10 %FIRST EPSS
Observed activity
isMalicious corpus · updated 2026-11-04 09:37 UTCBlock these indicators
- Firewall list (EDL, text): https://api.ismalicious.com/edl/cve/CVE-2015-7560?format=txt
- CSV export: https://api.ismalicious.com/edl/cve/CVE-2015-7560?format=csv
- TAXII collection of exploited CVEs
- The EDL and CSV take an API key on the Pro plan.
Versions per branch
NVD| Branch | Affected | Fixed in | Source |
|---|---|---|---|
| 4.3 | ≥ 4.3.0, < 4.3.6 | 4.3.6 | NVD |
| 4.2 | ≥ 4.2.0, < 4.2.9 | 4.2.9 | NVD |
| 4.1 | ≥ 3.2.0, < 4.1.23 | 4.1.23 | NVD |
| 4.4 | = 4.4.0 | no fix published | NVD |
| Branch | Affected | Fixed in | Source |
|---|---|---|---|
| 12.4 | = 12.04 | no fix published | NVD |
| 14.4 | = 14.04 | no fix published | NVD |
| 15.10 | = 15.10 | no fix published | NVD |
| Branch | Affected | Fixed in | Source |
|---|---|---|---|
| 7.0 | = 7.0 | no fix published | NVD |
| 8.0 | = 8.0 | no fix published | NVD |
as publishedRanges as NVD and OSV publish them; a distribution’s build can be fixed under an older number.
Distribution builds and vendor advisories
Packages from OSV.dev and products from the vendors' CSAF advisories.
version not verifiedVersions not verified: read as OSV.dev and the vendors publish them, not checked against each vendor's release list.
Packages
- sambaUbuntu:16.04:LTSall versions · fixed in 2:4.3.6+dfsg-1ubuntu1
- sambaUbuntu:14.04:LTSall versions · fixed in 2:4.1.6+dfsg-1ubuntu2.14.04.13
- sambaSUSE:Linux Enterprise Software Development Kit 12 SP1all versions · fixed in 4.2.4-11.1
- sambaSUSE:Linux Enterprise Software Development Kit 12all versions · fixed in 4.1.12-18.8.1
- sambaSUSE:Linux Enterprise Software Development Kit 11 SP4all versions · fixed in 3.6.3-67.2
- sambaSUSE:Linux Enterprise Server for SAP Applications 12 SP1all versions · fixed in 4.2.4-11.1
- sambaSUSE:Linux Enterprise Server for SAP Applications 12all versions · fixed in 4.1.12-18.8.1
- sambaSUSE:Linux Enterprise Server for SAP Applications 11 SP4all versions · fixed in 3.6.3-67.2and 1 other package
29 more package ranges on OSV.dev
Fix
- Update Samba to 4.3.6 · 4.2.9 · 4.1.23
Advisories and patches
- bugzilla.samba.orgVendor Advisory
- www.samba.orgVendor Advisory
Detection
- Nuclei template
- none so far ProjectDiscovery
- Exploit-DB
- no entry Exploit-DB
- Proof-of-concept repositories
- none listed PoC-in-GitHub
- Metasploit modules
- none listed Metasploit Framework
Sources
- NVDCVSS 3.16.5read 2026-10-23
- NVDCVSS 2.04read 2026-10-23
- NVDweakness (CWE)CWE-284read 2026-10-23
- FIRST EPSSEPSS score12.9 %read 2026-11-03
- OSVaffected packages—
Identifiers
- EUVD-2015-7472same flawENISA EUVD · LicenseRef-ENISA-legal-notice
- DSA-3514-1advisory covering several CVEsDebian · LicenseRef-unstated
- MGASA-2016-0106advisory covering several CVEsMageia · LicenseRef-unstated
- openSUSE-SU-2024:10069-1advisory covering several CVEsopenSUSE · LicenseRef-unstated
- RHSA-2016:0447advisory covering several CVEsRed Hat · CC-BY-4.0
- RHSA-2016:0448advisory covering several CVEsRed Hat · CC-BY-4.0
- RHSA-2016:0449advisory covering several CVEsRed Hat · CC-BY-4.0
- SUSE-SU-2016:0814-1advisory covering several CVEsSUSE · LicenseRef-unstated
- SUSE-SU-2016:0816-1advisory covering several CVEsSUSE · LicenseRef-unstated
- SUSE-SU-2016:0837-1advisory covering several CVEsSUSE · LicenseRef-unstated
- SUSE-SU-2016:0905-1advisory covering several CVEsSUSE · LicenseRef-unstated
Technical details
- CVSS v3 Vector
- CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N
- Published
- 2016-03-13
- Last Modified
- 2026-06-17
- NVD status
- Modified
Frequently asked questions
What is CVE-2015-7560?
Is CVE-2015-7560 actively exploited?
What is the CVSS score for CVE-2015-7560?
Running samba? Hear about its next vulnerability
Surveillance reads the versions in your stack — a domain, a lockfile or a list — checks each CVE against the ranges its sources publish, and alerts you when one you run is exploited or enters CISA KEV. A version it cannot read stays « version not verified ».
No credit card required · No monthly cap on website lookups · 250 API requests/month
Go further
- Following what attackers exploit right now? The CISA KEV additions of the month, with their patch deadlines.
- Running this software? Vulnerability monitoring alerts you to new vulnerabilities in your products.
Related vulnerabilities
Same product first, then the same vendor advisory and the same publication week.
Sources for this record
- CVE Program · CVE Program Terms of Use
- ENISA EU Vulnerability Database · ENISA legal notice §1.2 (reproduction authorised, provided the source is acknowledged)
- FIRST EPSS · EPSS terms of use (free use, attribution requested)
- NVD · Public domain (17 U.S.C. § 105) for NVD-authored data; third-party content under its own terms
- OSV.dev · Per record, as its publisher states it: each row carries the label in sourceLicense when one is served