CVE-2011-3923
A public proof of concept exists; no exploitation attested.
- Published2019-11-01
- Fixed in2.3.1.2
- WeaknessCWE-732
Am I affected?
Debian, Ubuntu or Red Hat sometimes backport a fix without changing the upstream version number: such a version reads « to verify », never « affected ».With a domain, we read the version its public headers and pages expose. A distribution build can carry the fix under an older number.
Description
Apache Struts before 2.3.1.2 allows remote attackers to bypass security protections in the ParameterInterceptor class and execute arbitrary commands.
Timeline
dates in UTC- 2013-03-22Exploit-DB entryExploit-DB
Versions per branch
NVD · OSV| Branch | Affected | Fixed in | Source |
|---|---|---|---|
| 2.x | ≥ 2.0.0, < 2.3.1.2 | 2.3.1.2 | NVD · OSV |
| Branch | Affected | Fixed in | Source |
|---|---|---|---|
| 1.0 | = 1.0.0 | no fix published | NVD |
as publishedRanges as NVD and OSV publish them; a distribution’s build can be fixed under an older number.
Fix
- Update Apache struts to 2.3.1.2
Detection
read 2026-11-04 22:56 UTC- Nuclei template
- none so far ProjectDiscovery
- Metasploit modules
- 1 moduleexploit/multi/http/struts_code_exec_parametersrank: excellentModule metadata: Metasploit Framework, © Rapid7, Inc., BSD-3-Clause. Metasploit Framework
Sources
- NVDCVSS 3.19.8read 2026-10-23
- NVDCVSS 2.07.5read 2026-10-23
- NVDweakness (CWE)CWE-732read 2026-10-23
- FIRST EPSSEPSS score89.5 %read 2026-11-04
- Exploit-DBdetectionread 2026-11-04
- Metasploit FrameworkMetasploit modules1known since 2026-11-01
- OSVaffected packages—
- GitHub AdvisoriesadvisoryCRITICAL2022-11-03
Identifiers
- EUVD-2022-1771same flawENISA EUVD · LicenseRef-ENISA-legal-notice
- GHSA-j68f-8h6p-9h5qsame flawGitHub Advisory Database · CC-BY-4.0
- exploit/multi/http/struts_code_exec_parametersexploit moduleMetasploit Framework © Rapid7 · BSD-3-Clause
Technical details
- CVSS v3 Vector
- CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- Published
- 2019-11-01
- Last Modified
- 2026-06-16
- NVD status
- Modified
- GitHub Advisory
- GHSA-j68f-8h6p-9h5q
Frequently asked questions
What is CVE-2011-3923?
Is CVE-2011-3923 actively exploited?
What is the CVSS score for CVE-2011-3923?
Hear about the next vulnerability in your software
Surveillance reads the versions in your stack — a domain, a lockfile or a list — checks each CVE against the ranges its sources publish, and alerts you when one you run is exploited or enters CISA KEV. A version it cannot read stays « version not verified ».
No credit card required · No monthly cap on website lookups · 250 API requests/month
Go further
- Following what attackers exploit right now? The CISA KEV additions of the month, with their patch deadlines.
- Running this software? Vulnerability monitoring alerts you to new vulnerabilities in your products.
Related vulnerabilities
Same product first, then the same vendor advisory and the same publication week.
Sources for this record
- CVE Program · CVE Program Terms of Use
- ENISA EU Vulnerability Database · ENISA legal notice §1.2 (reproduction authorised, provided the source is acknowledged)
- Exploit-DB · Exploit-DB terms of service · terms restrict redistribution
- FIRST EPSS · EPSS terms of use (free use, attribution requested)
- GitHub Advisory Database · CC-BY-4.0 · GHSA-j68f-8h6p-9h5q
- Metasploit Framework · BSD-3-Clause
- NVD · Public domain (17 U.S.C. § 105) for NVD-authored data; third-party content under its own terms
- OSV.dev · Per record, as its publisher states it: each row carries the label in sourceLicense when one is served