Skip to main content
No exploitation reportedFix available

CVE-2007-4465

No exploitation reported by the sources we read.

  • Published2007-09-14
  • Fixed in2.2.6 · 2.0.61
  • WeaknessCWE-79

Am I affected?

With a domain, we read the version its public headers and pages expose. A distribution build can carry the fix under an older number.

Description

Cross-site scripting (XSS) vulnerability in mod_autoindex.c in the Apache HTTP Server before 2.2.6, when the charset on a server-generated page is not defined, allows remote attackers to inject arbitrary web script or HTML via the P parameter using the UTF-7 charset. NOTE: it could be argued that this issue is due to a design limitation of browsers that attempt to perform automatic content type detection.

Timeline

dates in UTC
  1. 2007-09-1400:17CVE publishedNVD
  2. 2026-10-2319:23EPSS crossed 10 %FIRST EPSS

Observed activity

isMalicious corpus · updated 2026-11-04 03:37 UTC
Indicators tagged with this CVE, per day0 indicators over 7 days
Block these indicators
  • Firewall list (EDL, text): https://api.ismalicious.com/edl/cve/CVE-2007-4465?format=txt
  • CSV export: https://api.ismalicious.com/edl/cve/CVE-2007-4465?format=csv
  • TAXII collection of exploited CVEs
  • The EDL and CSV take an API key on the Pro plan.

Versions per branch

NVD
Apache HTTP Server
BranchAffectedFixed in
2.2≥ 2.2.0, < 2.2.62.2.6
2.0≥ 2.0.0, < 2.0.612.0.61

as publishedRanges as NVD and OSV publish them; a distribution’s build can be fixed under an older number.

Distribution builds and vendor advisories

Packages from OSV.dev and products from the vendors' CSAF advisories.

version not verifiedVersions not verified: read as OSV.dev and the vendors publish them, not checked against each vendor's release list.

Packages

  • antRed Hat:certificate_system:7.3all versions · fixed in 0:1.6.5-1jpp_1rh
  • apacheRed Hat:enterprise_linux:2.1::wsall versions · fixed in 0:1.3.27-14.entand 2 other packages
  • apacheRed Hat:enterprise_linux:2.1::esall versions · fixed in 0:1.3.27-14.entand 2 other packages
  • apacheRed Hat:enterprise_linux:2.1::awall versions · fixed in 0:1.3.27-14.entand 2 other packages
  • apacheRed Hat:enterprise_linux:2.1::asall versions · fixed in 0:1.3.27-14.entand 2 other packages
  • apache2openSUSE:Tumbleweedall versions · fixed in 2.4.49-1.1
  • apache2Debian:14all versions · fixed in 2.2.6-1
  • apache2Debian:13all versions · fixed in 2.2.6-1

78 more package ranges on OSV.dev

Vendor advisories

  • RHSA-2010:0602 Red Hat Product Security114 products fixed

    Red Hat Security Advisory: Red Hat Certificate System 7.3 security update

  • RHSA-2008:0524 Red Hat Product Security24 products fixed

    Red Hat Security Advisory: Red Hat Network Satellite Server security update

  • RHSA-2008:0523 Red Hat Product Security6 products fixed

    Red Hat Security Advisory: Red Hat Network Proxy Server security update

  • RHSA-2008:0261 Red Hat Product Security12 products fixed

    Red Hat Security Advisory: Red Hat Network Satellite Server security update

Full record on NVD

Fix

  1. Update Apache HTTP Server to 2.2.6 · 2.0.61
  2. Vendor fix Red Hat Product Security RHSA-2010:0602 · 114 productsBefore applying this update, make sure all previously-released errata relevant to your system have been applied. This update is available via the Red Hat Network. Details on how to use the Red Hat Network to apply this update are available at http://kbase.redhat.com/faq/docs/DOC-11259
  3. Vendor fix Red Hat Product Security RHSA-2008:0524 · 24 productsThis update is available via Red Hat Network. Details on how to use the Red Hat Network to apply this update are available at http://www.redhat.com/docs/manuals/satellite/Red_Hat_Network_Satellite-5.0.0/html/Installation_Guide/s1-maintenance-update.html
  4. Vendor fix Red Hat Product Security RHSA-2008:0523 · 6 productsBefore applying this update, make sure that all previously-released errata relevant to your system have been applied. This update is available via Red Hat Network. Details on how to use the Red Hat Network to apply this update are available at http://kbase.redhat.com/faq/FAQ_58_10188

Advisories and patches

Detection

Nuclei template
none so far
ProjectDiscovery
Exploit-DB
no entry
Exploit-DB
Proof-of-concept repositories
none listed
PoC-in-GitHub
Metasploit modules
none listed
Metasploit Framework

Sources

Identifiers

Technical details

CVSS v3 Vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Published
2007-09-14
Last Modified
2026-06-16
NVD status
Modified
GitHub Advisory
GHSA-7286-985c-74qv

Frequently asked questions

What is CVE-2007-4465?

Cross-site scripting (XSS) vulnerability in mod_autoindex.c in the Apache HTTP Server before 2.2.6, when the charset on a server-generated page is not defined, allows remote attackers to inject arbitrary web script or HTML via the P parameter using the UTF-7 charset. NOTE: it could be argued that this issue is due to a design limitation of browsers that attempt to perform automatic content type detection.

Is CVE-2007-4465 actively exploited?

Active exploitation of CVE-2007-4465 has not been confirmed. Its EPSS score was 26.2% on 2026-11-03, the estimated probability of exploitation in the next 30 days.

What is the CVSS score for CVE-2007-4465?

CVE-2007-4465 has a CVSS v3 base score of 6.1 (MEDIUM severity), with vector string CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N.

Running Red Hat Network Satellite Server? Hear about its next vulnerability

Surveillance reads the versions in your stack — a domain, a lockfile or a list — checks each CVE against the ranges its sources publish, and alerts you when one you run is exploited or enters CISA KEV. A version it cannot read stays « version not verified ».

No credit card required · No monthly cap on website lookups · 250 API requests/month

Related vulnerabilities

Same product first, then the same vendor advisory and the same publication week.

Sources for this record