Skip to main content
No exploitation reportedFix available

CVE-2026-67591

No exploitation reported by the sources we read.

  • Published2026-08-05
  • Fixed in1.2.0
  • WeaknessCWE-770

Am I affected?

With a domain, we read the version its public headers and pages expose. A distribution build can carry the fix under an older number.

Description

An authenticated attacker could exceed the session flow control incoming window potentially leading to denial of service. This issue affects Apache Qpid ProtonJ2: through 1.1.0. Users are recommended to upgrade to version 1.2.0, which fixes the issue.

Timeline

dates in UTC
  1. 2026-08-0507:16CVE publishedNVD

Versions per branch

NVD
Apache qpid protonj2
BranchAffectedFixed in
1.2< 1.2.01.2.0

as publishedRanges as NVD and OSV publish them; a distribution’s build can be fixed under an older number.

Products declared by the CNA1 product

As apache, the CNA that assigned this CVE, declared them in the CVE record; versions as written.

Source: the CNA record (CVE Program), © The MITRE Corporation,CVE Terms of UseCVE recordupdated 2026-08-05

Distribution builds and vendor advisories

Packages from OSV.dev and products from the vendors' CSAF advisories.

version not verifiedVersions not verified: read as OSV.dev and the vendors publish them, not checked against each vendor's release list.

Packages

  • qpid-protonUbuntu:26.10all versions · no fixed version listed
  • qpid-protonUbuntu:26.04:LTSall versions · no fixed version listed
  • qpid-protonUbuntu:24.04:LTSall versions · no fixed version listed
  • qpid-protonUbuntu:22.04:LTSall versions · no fixed version listed
  • qpid-protonUbuntu:20.04:LTSall versions · no fixed version listed
  • qpid-protonUbuntu:18.04:LTSall versions · no fixed version listed
  • qpid-protonUbuntu:16.04:LTSall versions · no fixed version listed

Vendor advisories

  • CVE-2026-67591 Red Hat Product Security2 known affected

    Apache Qpid ProtonJ2: Apache Qpid ProtonJ2: Denial of Service via exceeding session flow control window

    protonj2-parent as a component of Red Hat AMQ Broker 7 · protonj2-test-driver as a component of Red Hat AMQ Broker 7

Full record on NVD

Fix

  1. Update Apache qpid protonj2 to 1.2.0
  2. Workaround from the vendor Red Hat Product Security CVE-2026-67591 · 2 productsEnsure authenticated access to AMQP endpoints is restricted to trusted clients to limit exposure to this DoS vulnerability.
  3. No fix available, says the vendor Red Hat Product Security CVE-2026-67591 · 2 productsFix deferred

Advisories and patches

Detection

Nuclei template
none so far
ProjectDiscovery
Exploit-DB
no entry
Exploit-DB
Proof of concept
Metasploit modules
none listed
Metasploit Framework

Sources

Identifiers

Technical details

CVSS v3 Vector
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H
Published
2026-08-05
Last Modified
2026-10-24
NVD status
Analyzed
GitHub Advisory
GHSA-xcxh-hgpq-crj6

Frequently asked questions

What is CVE-2026-67591?

An authenticated attacker could exceed the session flow control incoming window potentially leading to denial of service. This issue affects Apache Qpid ProtonJ2: through 1.1.0. Users are recommended to upgrade to version 1.2.0, which fixes the issue.

Is CVE-2026-67591 actively exploited?

Active exploitation of CVE-2026-67591 has not been confirmed. Its EPSS score was 0.7% on 2026-11-05, the estimated probability of exploitation in the next 30 days.

What is the CVSS score for CVE-2026-67591?

CVE-2026-67591 has a CVSS v3 base score of 6.5 (MEDIUM severity), with vector string CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H.

Running Apache Qpid ProtonJ2? Hear about its next vulnerability

Surveillance reads the versions in your stack — a domain, a lockfile or a list — checks each CVE against the ranges its sources publish, and alerts you when one you run is exploited or enters CISA KEV. A version it cannot read stays « version not verified ».

No credit card required · No monthly cap on website lookups · 250 API requests/month

Sources for this record