Skip to main content
No exploitation reported

CVE-2026-123023

agentscope-ai AgentScope Bash Tool _bash.py check_permissions authorization

No exploitation reported by the sources we read.

  • Published2026-11-05
  • WeaknessCWE-285 · CWE-863

Am I affected?

With a domain, we read the version its public headers and pages expose. A distribution build can carry the fix under an older number.

Description

A flaw has been found in agentscope-ai AgentScope up to 2.0.8. This affects the function check_permissions of the file src/agentscope/tool/_builtin/_bash.py of the component Bash Tool. This manipulation causes incorrect authorization. Remote exploitation of the attack is possible. The exploit has been published and may be used. Upgrading to version 2.0.9 mitigates this issue. Patch name: 6b43b13a46401e86abd3defeed9a8bfe5b37bc6d. It is recommended to upgrade the affected component.

Timeline

dates in UTC
  1. 2026-11-0513:30CVE publishedCNA

Versions per branch

Products declared by the CNA

As VulDB, the CNA that assigned this CVE, declared them in the CVE record; versions as written. NVD lists no product for this CVE yet: this is the only product data so far.

  • agentscope-ai AgentScope
    Affected
    • = 2.0.0no fix stated
    • = 2.0.1no fix stated
    • = 2.0.2no fix stated
    • = 2.0.3no fix stated
    • = 2.0.4no fix stated
    • = 2.0.5no fix stated
    • = 2.0.6no fix stated
    • = 2.0.7no fix stated

    2 more version lines in the CVE record.

Source: the CNA record (CVE Program), © The MITRE Corporation,CVE Terms of UseCVE recordupdated 2026-11-05

Neither OSV.dev nor the vendor advisories we read list affected versions for CVE-2026-123023 yet.

Full record on NVD

Fix

No fix published by the sources we read yet. NVD record

Detection

Nuclei template
none so far
ProjectDiscovery
Exploit-DB
no entry
Exploit-DB
Metasploit modules
none listed
Metasploit Framework

Sources

  • CNACVSS 4.06.92026-11-05
  • CNACVSS 3.17.32026-11-05
  • NVDCVSS 3.17.3read 2026-11-05
  • CNACVSS 3.07.32026-11-05
  • CNACVSS 2.07.52026-11-05
  • CNAweakness (CWE)CWE-285, CWE-8632026-11-05
  • NVDweakness (CWE)CWE-285, CWE-863read 2026-11-05

Identifiers

Technical details

CVSS v3 Vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L
CVSS 4.0 vector
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N/E:P/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X
Published
2026-11-05
Last Modified
2026-11-05
NVD status
Deferred

Frequently asked questions

What is CVE-2026-123023?

A flaw has been found in agentscope-ai AgentScope up to 2.0.8. This affects the function check_permissions of the file src/agentscope/tool/_builtin/_bash.py of the component Bash Tool. This manipulation causes incorrect authorization. Remote exploitation of the attack is possible. The exploit has been published and may be used. Upgrading to version 2.0.9 mitigates this issue. Patch name: 6b43b13a46401e86abd3defeed9a8bfe5b37bc6d. It is recommended to upgrade the affected component.

Is CVE-2026-123023 actively exploited?

Active exploitation of CVE-2026-123023 has not been confirmed.

What is the CVSS score for CVE-2026-123023?

CVE-2026-123023 has a CVSS v3 base score of 7.3 (HIGH severity), with vector string CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L.

Hear about the next vulnerability in your software

Surveillance reads the versions in your stack — a domain, a lockfile or a list — checks each CVE against the ranges its sources publish, and alerts you when one you run is exploited or enters CISA KEV. A version it cannot read stays « version not verified ».

No credit card required · No monthly cap on website lookups · 250 API requests/month

Sources for this record