CVE-2024-9823
No exploitation reported by the sources we read.
- Published2024-10-14
- Fixed in12.0.3 · 11.0.18 · 10.0.18 · 9.4.54
- WeaknessCWE-400
Am I affected?
Debian, Ubuntu or Red Hat sometimes backport a fix without changing the upstream version number: such a version reads « to verify », never « affected ».With a domain, we read the version its public headers and pages expose. A distribution build can carry the fix under an older number.
Description
There exists a security vulnerability in Jetty's DosFilter which can be exploited by unauthorized users to cause remote denial-of-service (DoS) attack on the server using DosFilter. By repeatedly sending crafted requests, attackers can trigger OutofMemory errors and exhaust the server's memory finally.
Timeline
dates in UTC- 2024-10-1415:15CVE publishedNVD
Versions per branch
NVD · CISA-ADP · OSV| Branch | Affected | Fixed in | Source |
|---|---|---|---|
| 12.0 | ≥ 12.0.0, < 12.0.3 | 12.0.3 | NVD · CISA-ADP · OSV |
| 11.0 | ≥ 11.0.0, < 11.0.18 | 11.0.18 | NVD · CISA-ADP · OSV |
| 10.0 | ≥ 10.0.0, < 10.0.18 | 10.0.18 | NVD · CISA-ADP · OSV |
| 9.x | ≥ 9.0.0, < 9.4.54 | 9.4.54 | NVD · CISA-ADP · OSV |
| Branch | Affected | Fixed in | Source |
|---|---|---|---|
| — | all versions | no fix published | NVD |
| Branch | Affected | Fixed in | Source |
|---|---|---|---|
| — | all versions | no fix published | NVD |
as publishedRanges as NVD and OSV publish them; a distribution’s build can be fixed under an older number.
Products declared by the CNA4 products
As eclipse, the CNA that assigned this CVE, declared them in the CVE record; versions as written.
- Eclipse Foundation Jettyother versions: not affected
package org.eclipse.jetty:jetty-servletshttps://repo.maven.apache.org/maven2/
Affected- ≥ 9.0.0, < 9.4.54fixed in 9.4.54semvar
- ≥ 10.0.0, < 10.0.18fixed in 10.0.18semvar
- ≥ 11.0.0, < 11.0.18fixed in 11.0.18semver
- Eclipse Jetty Jettyother versions: not affected
package org.eclipse.jetty.ee8:jetty-ee8-servletshttps://repo.maven.apache.org/maven2/
Affected- ≥ 12.0.0, < 12.0.3fixed in 12.0.3semvar
- Eclipse Jetty Jettyother versions: not affected
package org.eclipse.jetty.ee8:jetty-ee9-servletshttps://repo.maven.apache.org/maven2/
Affected- ≥ 12.0.0, < 12.0.3fixed in 12.0.3semver
- Eclipse Jetty Jettyother versions: not affected
package org.eclipse.jetty.ee8:jetty-ee10-servletshttps://repo.maven.apache.org/maven2/
Affected- ≥ 12.0.0, < 12.0.3fixed in 12.0.3semvar
Source: the CNA record (CVE Program), © The MITRE Corporation,CVE Terms of UseCVE recordupdated 2024-10-14
Distribution builds and vendor advisories
Packages from OSV.dev and products from the vendors' CSAF advisories.
version not verifiedVersions not verified: read as OSV.dev and the vendors publish them, not checked against each vendor's release list.
Packages
- apache-hopChainguardall versions · fixed in 2.15.0-r2and 1 other package
- cassandra-reaperWolfiall versions · fixed in 4.0.1-r1
- cassandra-reaperChainguardall versions · fixed in 4.0.1-r1
- cassandra-reaper-fipsCleanStartall versions · fixed in 3.8.0-r3
- cassandra-reaper-fipsCleanStartall versions · fixed in 3.6.1-r3
- cassandra-reaper-fipsCleanStartall versions · fixed in 3.7.1-r4
- cassandra-reaper-fipsCleanStartall versions · fixed in 3.8.0-r9
- hadoop-fips-3.3.6Chainguardall versions · no fixed version listedand 1 other package
20 more package ranges on OSV.dev
Fix
- Update Eclipse jetty to 12.0.3 · 11.0.18 · 10.0.18 · 9.4.54
Advisories and patches
- github.comVendor Advisory
- gitlab.eclipse.orgVendor Advisory
Detection
- Nuclei template
- none so far ProjectDiscovery
- Exploit-DB
- no entry Exploit-DB
- Proof of concept
- PoC-in-GitHubno public repository identifiedread 2026-11-07
- Metasploit modules
- none listed Metasploit Framework
Sources
- CISA-ADPSSVC decisionnone2024-10-15
- CNACVSS 3.15.3known since 2026-10-23
- NVDCVSS 3.17.5read 2026-10-23
- CNAweakness (CWE)CWE-400known since 2026-10-23
- FIRST EPSSEPSS score0.9 %2026-11-06
- OSVaffected packages—
- GitHub AdvisoriesadvisoryMODERATE2024-10-14
Identifiers
- CGA-2jwx-3ph9-6cvmsame flawChainguard · CC-BY-NC-ND-4.0
- CGA-366w-4qrp-7rgmsame flawChainguard · CC-BY-NC-ND-4.0
- CGA-3cqc-5fw9-9438same flawChainguard · CC-BY-NC-ND-4.0
- CGA-3jmp-9p3h-f5f4same flawChainguard · CC-BY-NC-ND-4.0
- CGA-4j84-525f-q9g8same flawChainguard · CC-BY-NC-ND-4.0
- CGA-5mwg-p8wh-q6w7same flawChainguard · CC-BY-NC-ND-4.0
- CGA-6grc-88jr-7ccwsame flawChainguard · CC-BY-NC-ND-4.0
- CGA-6wv7-2665-38p3same flawChainguard · CC-BY-NC-ND-4.0
- CGA-7r3x-2wgp-r4qrsame flawChainguard · CC-BY-NC-ND-4.0
- CGA-c933-fpfr-p8mgsame flawChainguard · CC-BY-NC-ND-4.0
- CGA-f5p8-pm95-p2ffsame flawChainguard · CC-BY-NC-ND-4.0
- CGA-fhf9-9hgr-c3p5same flawChainguard · CC-BY-NC-ND-4.0
- CGA-j8c4-w5qv-9p4vsame flawChainguard · CC-BY-NC-ND-4.0
- CGA-jhrc-jf2f-v9m2same flawChainguard · CC-BY-NC-ND-4.0
- CGA-jmhp-99rg-fxmmsame flawChainguard · CC-BY-NC-ND-4.0
- CGA-jpgf-mwq5-84qcsame flawChainguard · CC-BY-NC-ND-4.0
- CGA-q7cq-hgq3-88h8same flawChainguard · CC-BY-NC-ND-4.0
- CGA-vhg2-8v9m-v42wsame flawChainguard · CC-BY-NC-ND-4.0
- CGA-vj38-xpqg-wmh3same flawChainguard · CC-BY-NC-ND-4.0
- CGA-vm6w-gh35-j35msame flawChainguard · CC-BY-NC-ND-4.0
- CGA-wfrj-h25w-c3qjsame flawChainguard · CC-BY-NC-ND-4.0
- CGA-ww36-gq6r-gpj2same flawChainguard · CC-BY-NC-ND-4.0
- EUVD-2024-3062same flawENISA EUVD · LicenseRef-ENISA-legal-notice
- GHSA-7hcf-ppf8-5w5hsame flawGitHub Advisory Database · CC-BY-4.0
- GHSA-j26w-f9rq-mr2qsame flawGitHub Advisory Database · CC-BY-4.0
- DLA-4106-1advisory covering several CVEsDebian · LicenseRef-unstated
- DSA-5894-1advisory covering several CVEsDebian · LicenseRef-unstated
Technical details
- CVSS v3 Vector
- CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- Published
- 2024-10-14
- Last Modified
- 2026-06-17
- NVD status
- Modified
- GitHub Advisory
- GHSA-7hcf-ppf8-5w5h GHSA-j26w-f9rq-mr2q
Frequently asked questions
What is CVE-2024-9823?
Is CVE-2024-9823 actively exploited?
What is the CVSS score for CVE-2024-9823?
Running apache-hop? Hear about its next vulnerability
Surveillance reads the versions in your stack — a domain, a lockfile or a list — checks each CVE against the ranges its sources publish, and alerts you when one you run is exploited or enters CISA KEV. A version it cannot read stays « version not verified ».
No credit card required · No monthly cap on website lookups · 250 API requests/month
Go further
- Following what attackers exploit right now? The CISA KEV additions of the month, with their patch deadlines.
- Running this software? Vulnerability monitoring alerts you to new vulnerabilities in your products.
Related vulnerabilities
Same product first, then the same vendor advisory and the same publication week.
Sources for this record
- CVE Program · CVE Program Terms of Use
- ENISA EU Vulnerability Database · ENISA legal notice §1.2 (reproduction authorised, provided the source is acknowledged)
- FIRST EPSS · EPSS terms of use (free use, attribution requested)
- GitHub Advisory Database · CC-BY-4.0 · GHSA-7hcf-ppf8-5w5h, GHSA-j26w-f9rq-mr2q
- NVD · Public domain (17 U.S.C. § 105) for NVD-authored data; third-party content under its own terms
- OSV.dev · Per record, as its publisher states it: each row carries the label in sourceLicense when one is served
- CISA Vulnrichment · CC0-1.0