Skip to main content
No exploitation reportedFix available

CVE-2024-13009

No exploitation reported by the sources we read.

  • Published2025-05-08
  • Fixed in9.4.57.v20241219
  • WeaknessCWE-404

Am I affected?

With a domain, we read the version its public headers and pages expose. A distribution build can carry the fix under an older number.

Description

In Eclipse Jetty versions 9.4.0 to 9.4.56 a buffer can be incorrectly released when confronted with a gzip error when inflating a request body. This can result in corrupted and/or inadvertent sharing of data between requests.

Timeline

dates in UTC
  1. 2025-05-0818:15CVE publishedNVD

Versions per branch

OSV · NVD
jetty-server
BranchAffectedFixed in
9.4≥ 9.4.0, < 9.4.57.v202412199.4.57.v20241219
Eclipse jetty
BranchAffectedFixed in
9.4≥ 9.4.0, < 9.4.579.4.57

as publishedRanges as NVD and OSV publish them; a distribution’s build can be fixed under an older number.

Products declared by the CNA1 product

As eclipse, the CNA that assigned this CVE, declared them in the CVE record; versions as written.

  • Eclipse Foundation Jettyother versions: not affected
    Affected
    • ≥ 9.4.0, ≤ 9.4.56no fix statedsemver

Source: the CNA record (CVE Program), © The MITRE Corporation,CVE Terms of UseCVE recordupdated 2025-05-08

Distribution builds and vendor advisories

Packages from OSV.dev and products from the vendors' CSAF advisories.

version not verifiedVersions not verified: read as OSV.dev and the vendors publish them, not checked against each vendor's release list.

Packages

  • apache-hiveCleanStartall versions · fixed in 4.0.0-r1
  • apache-hiveCleanStartall versions · fixed in 3.1.3-r3
  • cassandra-reaperWolfiall versions · fixed in 3.8.0-r3
  • cassandra-reaperChainguardall versions · fixed in 3.8.0-r3
  • cassandra-reaper-fipsCleanStartall versions · fixed in 3.8.0-r3
  • cassandra-reaper-fipsCleanStartall versions · fixed in 3.6.1-r3
  • cassandra-reaper-fipsCleanStartall versions · fixed in 3.7.1-r4
  • cassandra-reaper-fipsCleanStartall versions · fixed in 3.8.0-r9

45 more package ranges on OSV.dev

Vendor advisories

  • CVE-2024-13009 Red Hat Product Security5 products fixed · 13 known affected

    jetty-server: Jetty: Gzip Request Body Buffer Corruption

    jetty-server as a component of A-MQ Clients 2 · jetty-server as a component of Red Hat build of Debezium 2 · jetty-server as a component of Red Hat build of Debezium 3 · +10 more

  • RHSA-2025:12511 Red Hat Product Security1 product fixed

    Red Hat Security Advisory: Streams for Apache Kafka 3.0.0 release and security update

  • RHSA-2025:9922 Red Hat Product Security1 product fixed

    Red Hat Security Advisory: Streams for Apache Kafka 2.9.1 release and security update

Full record on NVD

Fix

  1. Update jetty-server to 9.4.57.v20241219
  2. Vendor fix Red Hat Product Security RHSA-2025:12511 · 1 productBefore applying this update, make sure all previously released errata relevant to your system have been applied. For details on how to apply this update, refer to: https://access.redhat.com/articles/11258
  3. Workaround from the vendor Red Hat Product Security RHSA-2025:12511 · 1 productMitigation for this issue is either not available or the currently available options do not meet the Red Hat Product Security criteria comprising ease of use and deployment, applicability to widespread installation base, or stability.
  4. No fix available, says the vendor Red Hat Product Security CVE-2024-13009 · 3 productsAffected
  5. No fix planned, says the vendor Red Hat Product Security CVE-2024-13009 · 4 productsOut of support scope
  6. No fix planned, says the vendor Red Hat Product Security CVE-2024-13009 · 6 productsWill not fix

Advisories and patches

Detection

Nuclei template
none so far
ProjectDiscovery
Exploit-DB
no entry
Exploit-DB
Proof of concept
Metasploit modules
none listed
Metasploit Framework

Sources

  • NVDCVE recordread 2026-10-23
  • CISA-ADPSSVC decisionnone2025-05-08
  • CNACVSS 3.17.2known since 2026-10-23
  • CNAweakness (CWE)CWE-404known since 2026-10-23
  • FIRST EPSSEPSS score0.5 %2026-11-06
  • OSVaffected packages—
  • GitHub AdvisoriesadvisoryHIGH2025-05-08

Identifiers

Technical details

CVSS v3 Vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:L/I:L/A:N
Published
2025-05-08
Last Modified
2026-06-17
NVD status
Analyzed
GitHub Advisory
GHSA-q4rv-gq96-w7c5

Frequently asked questions

What is CVE-2024-13009?

In Eclipse Jetty versions 9.4.0 to 9.4.56 a buffer can be incorrectly released when confronted with a gzip error when inflating a request body. This can result in corrupted and/or inadvertent sharing of data between requests.

Is CVE-2024-13009 actively exploited?

Active exploitation of CVE-2024-13009 has not been confirmed. Its EPSS score was 0.5% on 2026-11-06, the estimated probability of exploitation in the next 30 days.

What is the CVSS score for CVE-2024-13009?

CVE-2024-13009 has a CVSS v3 base score of 7.2 (HIGH severity), with vector string CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:L/I:L/A:N.

Running jetty-server? Hear about its next vulnerability

Surveillance reads the versions in your stack — a domain, a lockfile or a list — checks each CVE against the ranges its sources publish, and alerts you when one you run is exploited or enters CISA KEV. A version it cannot read stays « version not verified ».

No credit card required · No monthly cap on website lookups · 250 API requests/month

Sources for this record