Skip to main content
No exploitation reportedFix available

CVE-2020-7059

No exploitation reported by the sources we read.

  • Published2020-02-10
  • Fixed in7.4.2 · 7.3.14 · 7.2.27
  • WeaknessCWE-125

Am I affected?

With a domain, we read the version its public headers and pages expose. A distribution build can carry the fix under an older number.

Description

When using fgetss() function to read data with stripping tags, in PHP versions 7.2.x below 7.2.27, 7.3.x below 7.3.14 and 7.4.x below 7.4.2 it is possible to supply data that will cause this function to read past the allocated buffer. This may lead to information disclosure or crash.

Timeline

dates in UTC
  1. 2020-02-1008:15CVE publishedNVD

Versions per branch

NVD · OSV
PHP
BranchAffectedFixed in
7.4≥ 7.4.0, < 7.4.27.4.2
7.3≥ 7.3.0, < 7.3.147.3.14
7.2≥ 7.2.0, < 7.2.277.2.27
Debian debian linux
BranchAffectedFixed in
8.0= 8.0no fix published
Opensuse leap
BranchAffectedFixed in
15.1= 15.1no fix published

2 more products in the sources.

as publishedRanges as NVD and OSV publish them; a distribution’s build can be fixed under an older number.

Distribution builds and vendor advisories

Packages from OSV.dev and products from the vendors' CSAF advisories.

version not verifiedVersions not verified: read as OSV.dev and the vendors publish them, not checked against each vendor's release list.

Packages

  • libzipRocky Linux:8all versions · fixed in 0:1.5.2-1.module+el8.4.0+414+2e7afcdd
  • libzipRed Hat:enterprise_linux:8::appstreamall versions · fixed in 0:1.5.2-1.module+el8.1.0+3189+a1bff096and 5 other packages
  • libzipAlmaLinux:8all versions · fixed in 1.5.2-1.module_el8.3.0+2009+b272fdefand 2 other packages
  • libzipAlmaLinux:8all versions · fixed in 1.5.2-1.module_el8.4.0+2229+b272fdefand 2 other packages
  • libzipAlmaLinux:8all versions · fixed in 1.5.2-1.module_el8.5.0+152+112d3b8cand 2 other packages
  • phpTuxCare:OracleLinux:6all versions · fixed in 5.3.3-50.el6_10.tuxcare.ol.els16and 26 other packages
  • phpRocky Linux:8all versions · fixed in 0:7.3.20-1.module+el8.4.0+414+2e7afcdd
  • phpRed Hat:enterprise_linux:8::appstreamall versions · fixed in 0:7.3.20-1.module+el8.2.0+7373+b272fdefand 53 other packages

68 more package ranges on OSV.dev

Vendor advisories

  • CVE-2020-7059 Red Hat Product Security605 products fixed · 133 known affected

    php: Out of bounds read in php_strip_tags_ex

    php.src as a component of Red Hat Enterprise Linux 5 · php53.src as a component of Red Hat Enterprise Linux 5 · php as a component of Red Hat Enterprise Linux 6 · +130 more

  • ICSA-26-027-02 CISA1 known affected

    Festo Didactic SE MES PC

    Festo Didactic SE MES PC shipped with Windows 10

  • RHSA-2020:5275 Red Hat Product Security304 products fixed

    Red Hat Security Advisory: rh-php73-php security, bug fix, and enhancement update

  • RHSA-2020:3662 Red Hat Product Security301 products fixed

    Red Hat Security Advisory: php:7.3 security, bug fix, and enhancement update

Full record on NVD

Fix

  1. Update PHP to 7.4.2 · 7.3.14 · 7.2.27
  2. Vendor fix CISA ICSA-26-027-02 · 1 productFesto Didactic has released Factory Control Panel as a replacement for XAMPP on its MES PCs. Contact technical support at services.didactic@festo.com to obtain the current version of Factory Control Panel which includes fixes for these vulnerabilities.
  3. Vendor fix Red Hat Product Security RHSA-2020:5275 · 304 productsFor details on how to apply this update, which includes the changes described in this advisory, refer to: https://access.redhat.com/articles/11258 After installing the updated packages, the httpd daemon must be restarted for the update to take effect.
  4. No fix planned, says the vendor Red Hat Product Security CVE-2020-7059 · 30 productsOut of support scope
  5. No fix planned, says the vendor Red Hat Product Security CVE-2020-7059 · 103 productsWill not fix

Advisories and patches

Detection

Nuclei template
none so far
ProjectDiscovery
Exploit-DB
no entry
Exploit-DB
Proof of concept
Metasploit modules
none listed
Metasploit Framework

Sources

  • CNACVSS 3.16.5known since 2026-10-23
  • NVDCVSS 3.19.1read 2026-10-23
  • NVDCVSS 2.06.4read 2026-10-23
  • CNAweakness (CWE)CWE-125known since 2026-10-23
  • NVDweakness (CWE)CWE-125read 2026-10-23
  • FIRST EPSSEPSS score7.4 %2026-11-06
  • OSVaffected packages—
  • GitHub Advisoriesadvisory—

Identifiers

Technical details

CVSS v3 Vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:H
Published
2020-02-10
Last Modified
2026-06-17
NVD status
Modified
GitHub Advisory
GHSA-q8qf-vj8v-x7r9

Frequently asked questions

What is CVE-2020-7059?

When using fgetss() function to read data with stripping tags, in PHP versions 7.2.x below 7.2.27, 7.3.x below 7.3.14 and 7.4.x below 7.4.2 it is possible to supply data that will cause this function to read past the allocated buffer. This may lead to information disclosure or crash.

Is CVE-2020-7059 actively exploited?

Active exploitation of CVE-2020-7059 has not been confirmed. Its EPSS score was 7.4% on 2026-11-06, the estimated probability of exploitation in the next 30 days.

What is the CVSS score for CVE-2020-7059?

CVE-2020-7059 has a CVSS v3 base score of 9.1 (CRITICAL severity), with vector string CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:H.

Running PHP? Hear about its next vulnerability

Surveillance reads the versions in your stack — a domain, a lockfile or a list — checks each CVE against the ranges its sources publish, and alerts you when one you run is exploited or enters CISA KEV. A version it cannot read stays « version not verified ».

No credit card required · No monthly cap on website lookups · 250 API requests/month

Sources for this record