Skip to main content
No exploitation reportedFix available

CVE-2018-18313

No exploitation reported by the sources we read.

  • Published2018-12-07
  • Fixed in5.26.3
  • WeaknessCWE-125

Am I affected?

With a domain, we read the version its public headers and pages expose. A distribution build can carry the fix under an older number.

Description

Perl before 5.26.3 has a buffer over-read via a crafted regular expression that triggers disclosure of sensitive information from process memory.

Timeline

dates in UTC
  1. 2018-12-0721:29CVE publishedNVD

Versions per branch

NVD
Perl
BranchAffectedFixed in
5.26< 5.26.35.26.3
Canonical ubuntu linux
BranchAffectedFixed in
12.4= 12.04no fix published
14.4= 14.04no fix published
16.4= 16.04no fix published
18.4= 18.04no fix published
18.10= 18.10no fix published
Redhat enterprise linux
BranchAffectedFixed in
6.0= 6.0no fix published
7.0= 7.0no fix published
7.4= 7.4no fix published
7.5= 7.5no fix published
7.6= 7.6no fix published

6 more products in the sources.

as publishedRanges as NVD and OSV publish them; a distribution’s build can be fixed under an older number.

Distribution builds and vendor advisories

Packages from OSV.dev and products from the vendors' CSAF advisories.

version not verifiedVersions not verified: read as OSV.dev and the vendors publish them, not checked against each vendor's release list.

Packages

  • perlUbuntu:18.04:LTSall versions · fixed in 5.26.1-6ubuntu0.3
  • perlUbuntu:16.04:LTSall versions · fixed in 5.22.1-9ubuntu0.6
  • perlUbuntu:14.04:LTSall versions · fixed in 5.18.2-2ubuntu1.7
  • perlSUSE:Linux Enterprise Module for Development Tools 15all versions · fixed in 5.26.1-7.6.1
  • perlSUSE:Linux Enterprise Module for Basesystem 15all versions · fixed in 5.26.1-7.6.1
  • perlRed Hat:hummingbird:1all versions · fixed in 0:5.42.2-524.1.hum1and 10 other packages
  • perlDebian:14all versions · fixed in 5.28.0-3
  • perlDebian:13all versions · fixed in 5.28.0-3

149 more package ranges on OSV.dev

Vendor advisories

  • CVE-2018-18313 Red Hat Product Security674 products fixed

    perl: Heap-based buffer read overflow in S_grok_bslash_N()

  • RHSA-2026:7604 Red Hat Product Security203 products fixed

    Red Hat Security Advisory: Red Hat Hardened Images RPMs bug fix and enhancement update

  • RHSA-2019:0010 Red Hat Product Security217 products fixed

    Red Hat Security Advisory: rh-perl524-perl security update

  • RHSA-2019:0001 Red Hat Product Security254 products fixed

    Red Hat Security Advisory: rh-perl526-perl security and enhancement update

Full record on NVD

Fix

  1. Update Perl to 5.26.3
  2. Vendor fix Red Hat Product Security RHSA-2026:7604 · 203 productsFor details on how to apply this update, which includes the changes described in this advisory, refer to: https://images.redhat.com/
  3. Vendor fix Red Hat Product Security RHSA-2019:0010 · 217 productsFor details on how to apply this update, which includes the changes described in this advisory, refer to: https://access.redhat.com/articles/11258

Advisories and patches

Detection

Nuclei template
none so far
ProjectDiscovery
Exploit-DB
no entry
Exploit-DB
Proof of concept
Metasploit modules
none listed
Metasploit Framework

Sources

  • NVDCVSS 3.09.1read 2026-10-23
  • NVDCVSS 2.06.4read 2026-10-23
  • NVDweakness (CWE)CWE-125read 2026-10-23
  • FIRST EPSSEPSS score9.5 %2026-11-06
  • OSVaffected packages—

Identifiers

Technical details

CVSS v3 Vector
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:H
Published
2018-12-07
Last Modified
2026-06-17
NVD status
Modified

Frequently asked questions

What is CVE-2018-18313?

Perl before 5.26.3 has a buffer over-read via a crafted regular expression that triggers disclosure of sensitive information from process memory.

Is CVE-2018-18313 actively exploited?

Active exploitation of CVE-2018-18313 has not been confirmed. Its EPSS score was 9.5% on 2026-11-06, the estimated probability of exploitation in the next 30 days.

What is the CVSS score for CVE-2018-18313?

CVE-2018-18313 has a CVSS v3 base score of 9.1 (CRITICAL severity), with vector string CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:H.

Running Perl? Hear about its next vulnerability

Surveillance reads the versions in your stack — a domain, a lockfile or a list — checks each CVE against the ranges its sources publish, and alerts you when one you run is exploited or enters CISA KEV. A version it cannot read stays « version not verified ».

No credit card required · No monthly cap on website lookups · 250 API requests/month

Sources for this record