Skip to main content
No exploitation reportedFix available

CVE-2016-5624

No exploitation reported by the sources we read.

  • Published2016-10-25
  • Fixed in10.1.18 · 10.0.28 · 5.5.52

Am I affected?

With a domain, we read the version its public headers and pages expose. A distribution build can carry the fix under an older number.

Description

Unspecified vulnerability in Oracle MySQL 5.5.51 and earlier allows remote authenticated users to affect availability via vectors related to DML.

Timeline

dates in UTC
  1. 2016-10-2514:31CVE publishedNVD

Versions per branch

NVD
MariaDB
BranchAffectedFixed in
10.1≥ 10.1.0, < 10.1.1810.1.18
10.0≥ 10.0.0, < 10.0.2810.0.28
5.5≥ 5.5.0, < 5.5.525.5.52
Redhat enterprise linux eus
BranchAffectedFixed in
7.3= 7.3no fix published
7.4= 7.4no fix published
7.5= 7.5no fix published
7.6= 7.6no fix published
7.7= 7.7no fix published
Redhat enterprise linux server aus
BranchAffectedFixed in
7.3= 7.3no fix published
7.4= 7.4no fix published
7.6= 7.6no fix published
7.7= 7.7no fix published

5 more products in the sources.

as publishedRanges as NVD and OSV publish them; a distribution’s build can be fixed under an older number.

Distribution builds and vendor advisories

Packages from OSV.dev and products from the vendors' CSAF advisories.

version not verifiedVersions not verified: read as OSV.dev and the vendors publish them, not checked against each vendor's release list.

Packages

  • lz4SUSE:Linux Enterprise Software Development Kit 12 SP5all versions · fixed in 1.8.0-3.5.2
  • lz4SUSE:Linux Enterprise Server for SAP Applications 12 SP5all versions · fixed in 1.8.0-3.5.2
  • lz4SUSE:Linux Enterprise Server 12 SP5all versions · fixed in 1.8.0-3.5.2
  • mariadbSUSE:Linux Enterprise Workstation Extension 12 SP2all versions · fixed in 10.0.28-17.2
  • mariadbSUSE:Linux Enterprise Workstation Extension 12 SP1all versions · fixed in 10.0.28-17.2
  • mariadbSUSE:Linux Enterprise Software Development Kit 12 SP2all versions · fixed in 10.0.28-17.2
  • mariadbSUSE:Linux Enterprise Software Development Kit 12 SP1all versions · fixed in 10.0.28-17.2
  • mariadbSUSE:Linux Enterprise Server for SAP Applications 12 SP2all versions · fixed in 10.0.28-17.2

42 more package ranges on OSV.dev

Vendor advisories

  • RHSA-2016:2927 Red Hat Product Security77 products fixed

    Red Hat Security Advisory: rh-mariadb100-mariadb security update

  • RHSA-2016:2928 Red Hat Product Security84 products fixed

    Red Hat Security Advisory: rh-mariadb101-mariadb security update

  • RHSA-2016:2595 Red Hat Product Security120 products fixed

    Red Hat Security Advisory: mariadb security and bug fix update

  • RHSA-2016:2131 Red Hat Product Security64 products fixed

    Red Hat Security Advisory: mariadb55-mariadb security update

  • RHSA-2016:2130 Red Hat Product Security64 products fixed

    Red Hat Security Advisory: mysql55-mysql security update

Full record on NVD

Fix

  1. Update MariaDB to 10.1.18 · 10.0.28 · 5.5.52
  2. Vendor fix Red Hat Product Security RHSA-2016:2927 · 77 productsFor details on how to apply this update, which includes the changes described in this advisory, refer to: https://access.redhat.com/articles/11258 After installing this update, the MariaDB server daemon (mysqld) will be restarted automatically.
  3. Vendor fix Red Hat Product Security RHSA-2016:2130 · 64 productsFor details on how to apply this update, which includes the changes described in this advisory, refer to: https://access.redhat.com/articles/11258 After installing this update, the MySQL server daemon (mysqld) will be restarted automatically.

Advisories and patches

Detection

Nuclei template
none so far
ProjectDiscovery
Exploit-DB
no entry
Exploit-DB
Proof of concept
Metasploit modules
none listed
Metasploit Framework

Sources

Identifiers

Technical details

CVSS v3 Vector
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H
Published
2016-10-25
Last Modified
2026-06-17
NVD status
Modified
GitHub Advisory
GHSA-5vcm-h7p5-9pr6

Frequently asked questions

What is CVE-2016-5624?

Unspecified vulnerability in Oracle MySQL 5.5.51 and earlier allows remote authenticated users to affect availability via vectors related to DML.

Is CVE-2016-5624 actively exploited?

Active exploitation of CVE-2016-5624 has not been confirmed. Its EPSS score was 5.1% on 2026-11-05, the estimated probability of exploitation in the next 30 days.

What is the CVSS score for CVE-2016-5624?

CVE-2016-5624 has a CVSS v3 base score of 6.5 (MEDIUM severity), with vector string CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H.

Running MariaDB? Hear about its next vulnerability

Surveillance reads the versions in your stack — a domain, a lockfile or a list — checks each CVE against the ranges its sources publish, and alerts you when one you run is exploited or enters CISA KEV. A version it cannot read stays « version not verified ».

No credit card required · No monthly cap on website lookups · 250 API requests/month

Sources for this record